• Type: Improvement
    • Resolution: Unresolved
    • Priority: Major
    • None
    • Hide

      ICOM is defined in modular and extensible way, with core concepts, metadata concepts, and their relations included in Section 3. In Section 4, the specific concepts and relations for each area of collaboration activities are defined in separate extension modules. The extension modules include Content, Document, Message, Presence, Address Book, Calendar, FreeBusy, TaskList, Forum, and Conference modules. Some of the extension modules integrate models from existing standards, such as Content Management Interoperability Services [CMIS], Java Content Repository API [JCR 2.0], Web Distributed Authoring and Versioning (WebDAV) [RFC4918], Internet Message Access Protocol (IMAP) [RFC2119], Simple Mail Transfer Protocol (SMTP) [RFC5321], Extensible Messaging and Presence Protocol (XMPP) [RFC3920], XMPP Instant Messaging and Presence [RFC3921], vCard MIME Directory Profile [RFC2426], Internet Calendaring and Scheduling Core Object Specification (iCalendar) [RFC5545], and Calendaring Extensions to WebDAV (CalDAV) [RFC4791].

      Content module defines the data model for a document or message. The content, multi-content , simple content, and online content form a composite design pattern.

      Document module defines the document model and the version control metadata model for documents.

      Message module defines the abstract message model, UnifiedMessage, and InstantMessage. It also defines a mixed in class called MimeConvertible, which includes UnifiedMessage and Document, that can be added as multi-part content of a UnifiedMessage.

      AddressBook module defines address book as a folder that contains contacts, which can include bookmarks to addressable entities in the directories, addresses, and other personal entries.

      Calendar module defines calendar as a folder that contains time management artifacts such as occurrences and occurrence series.

      TaskList module defines task list as a folder that contains task management artifacts such as tasks and task assignments.

      Forum module defines forum as a folder that contains sub-forums, topics, announcements, and discussions.

      Conference module defines conference as a folder for visual, audio, and chat transcripts of the conference sessions.

      Show
      ICOM is defined in modular and extensible way, with core concepts, metadata concepts, and their relations included in Section 3. In Section 4, the specific concepts and relations for each area of collaboration activities are defined in separate extension modules. The extension modules include Content, Document, Message, Presence, Address Book, Calendar, FreeBusy, TaskList, Forum, and Conference modules. Some of the extension modules integrate models from existing standards, such as Content Management Interoperability Services [CMIS] , Java Content Repository API [JCR 2.0] , Web Distributed Authoring and Versioning (WebDAV) [RFC4918] , Internet Message Access Protocol (IMAP) [RFC2119] , Simple Mail Transfer Protocol (SMTP) [RFC5321] , Extensible Messaging and Presence Protocol (XMPP) [RFC3920] , XMPP Instant Messaging and Presence [RFC3921] , vCard MIME Directory Profile [RFC2426] , Internet Calendaring and Scheduling Core Object Specification (iCalendar) [RFC5545] , and Calendaring Extensions to WebDAV (CalDAV) [RFC4791] . Content module defines the data model for a document or message. The content, multi-content , simple content, and online content form a composite design pattern. Document module defines the document model and the version control metadata model for documents. Message module defines the abstract message model, UnifiedMessage, and InstantMessage. It also defines a mixed in class called MimeConvertible, which includes UnifiedMessage and Document, that can be added as multi-part content of a UnifiedMessage. AddressBook module defines address book as a folder that contains contacts, which can include bookmarks to addressable entities in the directories, addresses, and other personal entries. Calendar module defines calendar as a folder that contains time management artifacts such as occurrences and occurrence series. TaskList module defines task list as a folder that contains task management artifacts such as tasks and task assignments. Forum module defines forum as a folder that contains sub-forums, topics, announcements, and discussions. Conference module defines conference as a folder for visual, audio, and chat transcripts of the conference sessions.
    • Hide

      Resolved in CSPRD 02 candidate as proposed earlier.

      Show
      Resolved in CSPRD 02 candidate as proposed earlier.

      [Comment 5] : Section 4: At beginning, a Short overview of all the extension modules, and short narrative for each would be helpful.

            Assignee:
            Eric Chan (Inactive)
            Reporter:
            Eric Chan (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Created:
              Updated: