Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: ODF 1.2
    • Component/s: OpenFormula
    • Labels:
      None
    • Proposal:
      Hide

      I propose that we rename the "B" function to "BINOM.DIST.RANGE". Consolidating the B and BINOMDIST functions cause implementation problems for vendors that do not have a 1 to 1 function mapping. Gnumeric currently uses BINOM.DIST.RANGE.

      Show
      I propose that we rename the "B" function to "BINOM.DIST.RANGE". Consolidating the B and BINOMDIST functions cause implementation problems for vendors that do not have a 1 to 1 function mapping. Gnumeric currently uses BINOM.DIST.RANGE.
    • Resolution:
      Hide

      Renamed the "B" function to "BINOM.DIST.RANGE".

      Show
      Renamed the "B" function to "BINOM.DIST.RANGE".

      Description

      The current OpenFormula draft defines both a BINOMDIST and B function that both determine probabilities for the binomial distribution. BINOMDIST yields the density and cumulutative distribution function while Byields the probabiity for arbitrary intervals.

      This is a confusing and unnecessary duplication. A single well defined function should be able to replace both.

      Moreover, the name "B" is awfully undescriptive.

        Attachments

          Activity

            People

            • Assignee:
              ericpa Eric Patterson
              Reporter:
              aguelzow Andreas Guelzow
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: