Affects Version/s: None
Fix Version/s: ODF 1.2 Part 2 CD 1
Change the description of ZTEST as outlined in teh attachment to
Changed the description of ZTEST as outlined in the attachment to
[Note: used shall instead of must]
== 6.17.86 ZTEST ==
The draft specification defines the result as 1-P(-|z| <= Z <= |z|),
which is a two-tailed form. But the current implementations use a
one-tailed form. Besides a real bug in OOo, Excel and OOo return
1-P( Z<=z) for z>=0 and
P( Z <= |z|) for z<0
Gnumeric returns P( Z <= |z|) for z<0 too, but I do not understand the
result in Gnumeric for z>=0.
In other cases of changed semantic, for example the change from right
tail to left tail in CHIDIST, for the old version LEGACY was introduced.
Shouldn't there be a differentiation in the case of ZTEST too? I know
the specification is only about the internal names and using a prefixed
name for the old version internally is possible. But the names in the
specification give a strong hint how the functions should be named in
the UI of the applications and unique names in different applications
would make working with different applications much easier for users.